PalmPay on Mobile Downtime

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.

We appreciate your patience and understanding.
Posted Jul 18, 2025 - 18:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2025 - 14:53 UTC

Investigating

We’ve identified an issue affecting PalmPay payments on mobile devices. Our team is actively working to resolve this as quickly as possible.

We sincerely apologize for any inconvenience caused.
Posted Jul 18, 2025 - 11:03 UTC
This incident affected: Wallet Payments (PalmPay).