Cameroon: Orange Money Downtime

Incident Report for Pay1st Incident

Investigating

This is a quick update to inform you that we are still experiencing instability with Orange Cameroon services, but our partner is working to restore the service to its optimal level.

We'll provide an update as soon as possible.
Posted Sep 12, 2026 - 10:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2026 - 23:41 UTC

Investigating

This is a quick update to inform you that we are experiencing a downtime in our Orange Cameroon services, but our partner is working to restore the service to its optimal level.

We'll provide an update as soon as possible.
Posted Sep 11, 2026 - 17:24 UTC
This incident affects: Mobile Money (Orange Money Cameroon).