Cameroon: Degraded Performance on Orange Money Cameroon

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted May 19, 2026 - 08:09 UTC

Monitoring

We are currently seeing degraded performance on Orange Money services in Cameroon. Our partner is aware of the issue and is actively working to resolve it as soon as possible.

We apologize for any inconvenience this may cause.
Posted May 18, 2026 - 23:25 UTC
This incident affected: Mobile Money (Orange Money Cameroon).