Airtel Money Zambia Downtime

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Mar 21, 2026 - 08:32 UTC

Investigating

We have observed an intermittent downtime with Zambia Airtel money transactions. This has been escalated to our partner and they are currently working on resolution . we will be providing feedback as soon as possible.
Posted Mar 20, 2026 - 23:31 UTC
This incident affected: Mobile Money (Airtel Mobile Money).