Egypt: Mobile Money Downtime

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 12:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2026 - 12:11 UTC

Investigating

We are currently experiencing a 100% transaction failure rate with mobile money payment methods in Egypt. The issue has been escalated to our partner, and we are actively following up to ensure a swift resolution.
Posted Sep 03, 2026 - 11:17 UTC
This incident affected: Mobile Money (Orange Money Egypt, Etisalat Egypt, Vodafone Egypt, WePay).