Ghana: AirtelTigo Degraded Performance

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Sep 05, 2026 - 18:29 UTC

Monitoring

We have observed an improvement in success rate and will keep monitoring for stability.
Posted Sep 05, 2026 - 14:04 UTC

Investigating

We have observed degraded performance on AirtelTigo services. We have escalated this to our partner, and we'll update you as soon as this is resolved.

We apologise for any inconvenience this may cause.
Posted Sep 05, 2026 - 12:04 UTC
This incident affected: Mobile Money (ATMoney Ghana).