Kenya: Downtime on M-Pesa Mobile Money Payment

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 16:50 UTC

Monitoring

We have noticed an improvement in success rate and will continue to monitor for stability
Posted Mar 22, 2026 - 16:12 UTC

Update

This is a quick update to inform you that we are still experiencing downtime on the M-Pesa method in Kenya. We are actively following up with our partner to ensure a swift resolution.

We will share an update as soon as service is restored.
Posted Mar 21, 2026 - 15:51 UTC

Investigating

We are currently experiencing a service disruption with M-Pesa Mobile Money in Kenya.

Our team is actively working with our partner to resolve the issue.

We will share updates as soon as more information becomes available.
Posted Mar 20, 2026 - 16:20 UTC
This incident affected: Mobile Money (Mpesa - Mobile Money).