A fix has been implemented and we are monitoring the results.
Posted May 13, 2026 - 14:05 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 13, 2026 - 09:25 UTC
Identified
This is a quick update to inform you that we are currently experiencing an intermittent downtime on USSD transactions. Our partner is working diligently with NIBSS to resolve the issue as quickly as possible.
Apologies for the inconvenience caused.
Posted May 13, 2026 - 09:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 23:41 UTC
Identified
We regret to inform you that we are currently experiencing an intermittent downtime on USSD transactions. Our partner is working diligently with NIBSS to resolve the issue as quickly as possible.
We will notify you as soon as the service is restored.
We apologise for any inconvenience caused.
Posted May 12, 2026 - 14:18 UTC
This incident affected: Bank Transfer - Nigeria (USSD).