Ghana: Degraded Performance on MTN, Telecel Cash & ATMoney

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.

We appreciate your patience and understanding.
Posted Sep 08, 2026 - 18:12 UTC

Update

This is a quick update to inform you that we are still experiencing instabilities with MTN, Telecel Cash and ATMoney services in Ghana. We are closely following up with our partner to ensure a full resolution.

We apologize for the inconvenience caused.
Posted Sep 08, 2026 - 12:57 UTC

Update

This is a quick update to inform you that we are experiencing an outage and instability in MTN MoMo & Telecel Cash services, and we are closely following up with our partner.

We'll provide an update as soon as possible.
Posted Sep 08, 2026 - 00:06 UTC

Investigating

We have observed an outage on MTN MoMo services. We have escalated this to our partner and will update you as soon as it is resolved.

We apologise for any inconvenience this may cause.
Posted Sep 07, 2026 - 20:01 UTC
This incident affected: Mobile Money (MTN MoMo Ghana, Telecel Cash Ghana, ATMoney Ghana).