Egypt : Downtime on Cards

Incident Report for Pay1st Incident

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2025 - 10:57 UTC

Investigating

We've observed an increase in failed Cards transactions in Egypt . This has been escalated to our partner and is being investigated.
We are expecting the service to be restored as soon as possible.
Posted Mar 02, 2025 - 14:06 UTC
This incident affects: Card Payments (Card Payment Egypt).