Morocco: Degraded Performance on Card Payments

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 17:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 15:36 UTC

Investigating

We have observed high failure rates with card payments in Morocco. This has been escalated to the Partner, and we will provide an update as soon as possible.
Posted Jul 17, 2025 - 09:31 UTC
This incident affected: Card Payments (Card Payment Morocco).