Kenya: Mpesa Degraded Performance

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 22:02 UTC

Monitoring

We are seeing improvements in the performance and are closely monitoring
Posted Apr 02, 2026 - 20:10 UTC

Investigating

We are experiencing instabilities with Mpesa transactions in Kenya. This has been escalated to our partner, and we are actively following up to ensure a swift resolution.

We apologize for the inconvenience caused.
Posted Apr 02, 2026 - 18:43 UTC
This incident affected: Mobile Money (Mpesa - Mobile Money).