Nigeria: Verve Cards Downtime

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Jul 20, 2025 - 10:20 UTC

Monitoring

A fix has been implemented, and we are now monitoring transactions.
Posted Jul 20, 2025 - 09:02 UTC

Investigating

We have observed a 100% failure rate on Verve Cards. We are in close contact with our partner to resolve this issue and will be sharing once it has been resolved.

We apologise for any inconvenience caused.
Posted Jul 20, 2025 - 07:48 UTC
This incident affected: Card Payments (Verve Card Nigeria).