Tanzania: Airtel Money Degraded Performance

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted May 08, 2026 - 07:50 UTC

Investigating

We are currently experiencing degraded performance with Airtel Money Tanzania services. Our partner is aware of the issue and is actively working to restore services to optimal levels.

We apologize for any inconvenience this may cause.
Posted May 07, 2026 - 23:59 UTC
This incident affected: Mobile Money (Airtel Money Tanzania).