Cameroon: Downtime on MTN MoMo

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted May 13, 2026 - 12:59 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident. Thank you for your patience.
Posted May 13, 2026 - 11:57 UTC

Investigating

We are currently experiencing downtime on MTN MoMo transactions in Cameroon. Our partner is aware of the issue and is actively working to resolve it as soon as possible.
Posted May 13, 2026 - 08:38 UTC
This incident affected: Mobile Money (MTN Money Cameroon).