Zambia: Zamtel Money Downtime

Incident Report for Pay1st Incident

Investigating

This is a quick update regarding the ongoing downtime of Zamtel services in Zambia. The system migration and platform upgrade are taking longer than initially anticipated, but the partner is actively working to restore service as soon as possible.

We sincerely apologize for the inconvenience caused.
Posted May 19, 2026 - 08:15 UTC

Update

We are still experiencing downtime with Zamtel Money, They are working on restoring their services and we will provide an update as soon as possible

Apologiea for the inconvenience
Posted May 17, 2026 - 14:30 UTC

Update

Unfortunately, the Zamtel Money system migration and platform upgrade is taking longer than initially anticipated. Zamtel is continuing to work on restoring services and we will share updates on service restoration.
Posted May 16, 2026 - 23:55 UTC

Identified

We are currently experiencing a downtime with Zamtel Money. Zamtel is working on restoring their services and we will provide an update as soon as possible.

Thank you for your patience.
Posted May 16, 2026 - 18:23 UTC
This incident affects: Mobile Money (Zamtel Money).