South Africa: Downtime On Cards

Incident Report for Pay1st Incident

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 18, 2026 - 15:53 UTC

Identified

We have temporarily suspended the card payment method due to an ongoing issue. We are actively investigating this internally and will share updates as more information becomes available.

We apologize for any inconvenience caused.
Posted May 17, 2026 - 20:00 UTC
This incident affects: Card Payments (Card Payment South Africa).