Kenya: Mpesa Downtime

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 10:36 UTC

Monitoring

A fix has been implemented, and we are monitoring for stability.
Posted Aug 31, 2026 - 08:58 UTC

Investigating

We are experiencing an outage with Mpesa services in Kenya. Our partner is actively working to resolve the issue.

We apologise for the inconvenience caused.
Posted Aug 31, 2026 - 08:13 UTC
This incident affected: Mobile Money (Mpesa - Mobile Money).