Saudi Arabia: Mada Payment Method Downtime

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted May 08, 2026 - 11:29 UTC

Investigating

We are currently experiencing a temporary downtime for payments via Mada Payment method due to an issue with one of our technical partners.

We're working with them to resolve this as quickly as possible and will provide an update as soon as possible.
Posted May 08, 2026 - 00:29 UTC
This incident affected: Card Payments (Card Payment Saudi Arabia).