Nigeria: Downtime in Paga Wallet and USSD transactions

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 16:51 UTC

Investigating

We regret to inform you that we are currently experiencing intermittent downtime on Paga Wallet and USSD transactions. Our partner is working to resolve the issue as quickly as possible.

We will notify you as soon as the service is restored.
Posted Mar 23, 2026 - 14:39 UTC
This incident affected: Wallet Payments (Paga Wallet) and Bank Transfer - Nigeria (USSD).