Ghana : Downtime on Card Transactions

Incident Report for Pay1st Incident

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2025 - 12:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2025 - 14:34 UTC

Investigating

We are seeing an increase in failure rate for card transactions in Ghana . This has been notified to our partner and we will providing updates until this issue is resolved.
Posted Feb 26, 2025 - 12:44 UTC
This incident affects: Card Payments (Card Payment Ghana).