Ghana: Telecel Cash Degraded Performance

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Aug 29, 2026 - 08:51 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 28, 2026 - 22:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2026 - 20:58 UTC

Investigating

We are seeing degraded performance with Telecel Cash (Vodafone) services in Ghana. We have escalated to our partner and are actively following up to ensure a prompt resolution.

We apologize for the inconvenience caused.
Posted Aug 28, 2026 - 16:01 UTC
This incident affected: Mobile Money (Telecel Cash Ghana).