Cameroon: Downtime on Orange Money

Incident Report for Pay1st Incident

Resolved

The incident has been resolved. We apologise for the inconvenience caused.
Posted Mar 26, 2026 - 10:31 UTC

Investigating

We are currently experiencing an outage on Orange MoMo in Cameroon. Our partner is aware of the issue and is actively working to resolve it as soon as possible.

We apologize for any inconvenience this may cause.
Posted Mar 26, 2026 - 09:01 UTC
This incident affected: Mobile Money (Orange Money Cameroon).