Egypt: WePay Downtime

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 11:01 UTC

Monitoring

A fix has been implemented, and we are monitoring transactions.
Posted Jul 23, 2025 - 09:35 UTC

Investigating

We have observed a 100% failure rate with WePay. This has been escalated to our partner, and we'll share an update once the issue has been resolved.

We apologise for any inconvenience caused.
Posted Jul 22, 2025 - 08:43 UTC
This incident affected: Mobile Money (WePay).