MTN MoMo Performance Degradation

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 21:11 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 18:58 UTC

Update

This is a quick update to inform you that we are experiencing an instability with MTN MoMo services, but our partner is working on restoring the services to an optimal level. We'll provide an update as soon as possible.
Posted Mar 26, 2026 - 14:54 UTC

Monitoring

We are seeing improvements in success rates, we will continue monitoring the incident and share updates on resolution.
Posted Mar 26, 2026 - 10:33 UTC

Investigating

We are currently experiencing an instability with MTN MoMo services. Our partner is aware of the issue and is actively working to resolve it as soon as possible.

We apologize for any inconvenience this may cause.
Posted Mar 26, 2026 - 08:29 UTC
This incident affected: Mobile Money (MTN Mobile Money, MTN Money Cameroon, MTN Money Uganda, MTN MoMo Zambia).