This incident has been resolved. Thank you for your patience.
Posted Apr 01, 2026 - 15:48 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 01, 2026 - 15:47 UTC
Monitoring
A fix has been implemented, and we are now monitoring for stability.
Posted Apr 01, 2026 - 13:42 UTC
Update
We are experiencing a major outage with Pay at Fawry. Our partner is working to resolve this issue promptly.
We apologize for any inconvenience caused.
Posted Apr 01, 2026 - 11:02 UTC
Update
This is a quick update to remind you that we are still experiencing degraded performance with Pay at Fawry. Our partner is working to resolve this issue promptly.
We apologize for any inconvenience caused.
Posted Apr 01, 2026 - 10:49 UTC
Identified
We’re currently experiencing degraded performance with Pay at Fawry.
Our team is working closely with the partner to resolve the issue urgently.
We’ll share updates as soon as service is restored.
Posted Apr 01, 2026 - 08:15 UTC
This incident affected: Cash Transfer (Pay at Fawry).