Cameroon: Downtime on Orange Mobile Money

Incident Report for Pay1st Incident

Resolved

This incident has been resolved
Posted Mar 24, 2026 - 14:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 08:42 UTC

Update

This is an update to inform you that we are still experiencing an instability on Orange MoMo in Cameroon. Our partner is aware of the issue and is actively working to resolve it as soon as possible.

We apologize for any inconvenience this may cause.
Posted Mar 23, 2026 - 14:00 UTC

Update

This is an update to inform you that we are still experiencing an outage on Orange MoMo in Cameroon. Our partner is aware of the issue and is actively working to resolve it as soon as possible.

We apologize for any inconvenience this may cause.
Posted Mar 21, 2026 - 15:48 UTC

Update

This is an update to inform you that we are still experiencing an outage on Orange MoMo in Cameroon. Our partner is aware of the issue and is actively working to resolve it as soon as possible.

We apologize for any inconvenience this may cause.
Posted Mar 20, 2026 - 00:03 UTC

Update

We are experiencing performance degradation on Orange Money transactions in Cameroon. Our partner is aware of the issue and is actively working to resolve it as soon as possible.

We apologize for the inconvenience and appreciate your patience.
Posted Mar 19, 2026 - 07:40 UTC

Investigating

We are currently experiencing an outage on Orange MoMo in Cameroon. Our partner is aware of the issue and is actively working to resolve it as soon as possible.

We apologize for any inconvenience this may cause.
Posted Mar 18, 2026 - 17:26 UTC
This incident affected: Mobile Money (Orange Money Cameroon).