Ghana: Vodafone Mobile Money Downtime

Incident Report for Pay1st Incident

Resolved

This incident has been resolved.
Posted Jul 19, 2025 - 20:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2025 - 17:50 UTC

Investigating

We are experiencing degraded performance on Vodafone mobile money transactions in Ghana . This has been escalated to our partner, and updates will be provided as soon as the issue is resolved.

We apologise for any inconvenience caused.
Posted Jul 19, 2025 - 14:48 UTC
This incident affected: Mobile Money (Vodafone Ghana).